<!DOCTYPE html>
<html lang="en-US">
	<head>
        <!-- set the viewport width and initial-scale on mobile devices -->
		<meta name="viewport" content="width=device-width, initial-scale=1.0, viewport-fit=cover">
        <!-- set the encoding of your site -->
		<meta charset="UTF-8">
        <!-- include custom JavaScript -->
		<script type="text/javascript">
			var pathInfo = {
				base: 'https://quimbyscruisingguide.com/wp-content/themes/quimbys/',
				css: 'css/',
				js: 'js/',
				swf: 'swf/',
			}
		</script>
		
		<!-- Global Site Tag (gtag.js) - Google Analytics -->
		<script async src="https://www.googletagmanager.com/gtag/js?id=UA-107221786-1"></script>
		<script>
		window.dataLayer = window.dataLayer || [];
		function gtag(){dataLayer.push(arguments)};
		gtag('js', new Date());

 		gtag('config', 'UA-107221786-1');
		</script>
	
		<script data-ad-client="ca-pub-3229429991634269" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>	

		<!-- Facebook Pixel Code -->
		<script>
		  !function(f,b,e,v,n,t,s)
		  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
		  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
		  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
		  n.queue=[];t=b.createElement(e);t.async=!0;
		  t.src=v;s=b.getElementsByTagName(e)[0];
		  s.parentNode.insertBefore(t,s)}(window, document,'script',
		  'https://connect.facebook.net/en_US/fbevents.js');
		  fbq('init', '439506903282920');
		  fbq('track', 'PageView');
		</script>
		<noscript>
		  <img height="1" width="1" style="display:none" 
		       src="https://www.facebook.com/tr?id=439506903282920&ev=PageView&noscript=1"/>
		</noscript>
		<!-- End Facebook Pixel Code -->	


		<!-- Start of HubSpot Embed Code -->
		 <script type="text/javascript" id="hs-script-loader" async defer src="//js.hs-scripts.com/3047308.js"></script>
		<!-- End of HubSpot Embed Code -->
		
		<link rel="preconnect" href="https://fonts.googleapis.com">
	<link rel="preconnect" href="https://fonts.gstatic.com" crossorigin="">
	<link href="https://fonts.googleapis.com/css2?family=Playfair+Display:wght@700&amp;family=Roboto:wght@400;700&amp;display=swap" rel="stylesheet"><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v18.7 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Entertaining on Board Your Boat - Quimby&#039;s Cruising Guide</title>
	<meta name="description" content="Hosting friends and family on board ranks as the No. 2 reason for having a boat on many U.S. boat owners’ lists." />
	<link rel="canonical" href="https://quimbyscruisingguide.com/moveable-feast/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Entertaining on Board Your Boat - Quimby&#039;s Cruising Guide" />
	<meta property="og:description" content="Hosting friends and family on board ranks as the No. 2 reason for having a boat on many U.S. boat owners’ lists." />
	<meta property="og:url" content="https://quimbyscruisingguide.com/moveable-feast/" />
	<meta property="og:site_name" content="Quimby&#039;s Cruising Guide" />
	<meta property="article:published_time" content="2022-06-02T15:34:08+00:00" />
	<meta property="article:modified_time" content="2022-06-02T19:04:24+00:00" />
	<meta property="og:image" content="https://quimbyscruisingguide.com/wp-content/uploads/2015/06/Boat-Grill.jpg" />
	<meta property="og:image:width" content="1257" />
	<meta property="og:image:height" content="835" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Quimbys Editor" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="4 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://quimbyscruisingguide.com/#website","url":"https://quimbyscruisingguide.com/","name":"Quimby&#039;s Cruising Guide","description":"The complete listing of marinas and locks","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://quimbyscruisingguide.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://quimbyscruisingguide.com/moveable-feast/#primaryimage","url":"https://quimbyscruisingguide.com/wp-content/uploads/2015/06/Boat-Grill.jpg","contentUrl":"https://quimbyscruisingguide.com/wp-content/uploads/2015/06/Boat-Grill.jpg","width":1257,"height":835,"caption":"Barbecue grill on the boat. Luxury boat party before sunset in Phuket, Thailand"},{"@type":"WebPage","@id":"https://quimbyscruisingguide.com/moveable-feast/#webpage","url":"https://quimbyscruisingguide.com/moveable-feast/","name":"Entertaining on Board Your Boat - Quimby&#039;s Cruising Guide","isPartOf":{"@id":"https://quimbyscruisingguide.com/#website"},"primaryImageOfPage":{"@id":"https://quimbyscruisingguide.com/moveable-feast/#primaryimage"},"datePublished":"2022-06-02T15:34:08+00:00","dateModified":"2022-06-02T19:04:24+00:00","author":{"@id":"https://quimbyscruisingguide.com/#/schema/person/4d86302f5314a3e7b5b21d1e31bcfb14"},"description":"Hosting friends and family on board ranks as the No. 2 reason for having a boat on many U.S. boat owners’ lists.","breadcrumb":{"@id":"https://quimbyscruisingguide.com/moveable-feast/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://quimbyscruisingguide.com/moveable-feast/"]}]},{"@type":"BreadcrumbList","@id":"https://quimbyscruisingguide.com/moveable-feast/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://quimbyscruisingguide.com/"},{"@type":"ListItem","position":2,"name":"Entertaining on Board Your Boat"}]},{"@type":"Person","@id":"https://quimbyscruisingguide.com/#/schema/person/4d86302f5314a3e7b5b21d1e31bcfb14","name":"Quimbys Editor","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://quimbyscruisingguide.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/?s=96&d=mm&r=g","caption":"Quimbys Editor"},"url":"https://quimbyscruisingguide.com/author/quimbys-editor/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//kit.fontawesome.com' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Quimby&#039;s Cruising Guide &raquo; Feed" href="https://quimbyscruisingguide.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Quimby&#039;s Cruising Guide &raquo; Comments Feed" href="https://quimbyscruisingguide.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Quimby&#039;s Cruising Guide &raquo; Entertaining on Board Your Boat Comments Feed" href="https://quimbyscruisingguide.com/moveable-feast/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/quimbyscruisingguide.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://quimbyscruisingguide.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='wpeasycart_css-css'  href='https://quimbyscruisingguide.com/wp-content/plugins/wp-easycart/design/theme/base-responsive-v3/ec-store.css?ver=5_3_4' type='text/css' media='all' />
<link rel='stylesheet' id='wpeasycart_gfont-css'  href='https://fonts.googleapis.com/css?family=Lato%7CMonda%7COpen+Sans%7CDroid+Serif%7CRoboto&#038;ver=6.0' type='text/css' media='all' />
<link rel='stylesheet' id='wpeasycart_owl_carousel_css-css'  href='https://quimbyscruisingguide.com/wp-content/plugins/wp-easycart/design/theme/base-responsive-v3/owl.carousel.css?ver=6.0' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://quimbyscruisingguide.com/wp-includes/css/dashicons.min.css?ver=6.0' type='text/css' media='all' />
<link rel='stylesheet' id='base-style-css'  href='https://quimbyscruisingguide.com/wp-content/themes/quimbys/style.css?ver=6.0' type='text/css' media='all' />
<link rel='stylesheet' id='base-theme-css'  href='https://quimbyscruisingguide.com/wp-content/themes/quimbys/theme.css?ver=6.0' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/3.6.0/jquery.min.js?ver=1' id='jquery-js'></script>
<script type='text/javascript' src='https://quimbyscruisingguide.com/wp-includes/js/jquery/ui/core.min.js?ver=1.13.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://quimbyscruisingguide.com/wp-includes/js/jquery/ui/accordion.min.js?ver=1.13.1' id='jquery-ui-accordion-js'></script>
<script type='text/javascript' src='https://quimbyscruisingguide.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.13.1' id='jquery-ui-datepicker-js'></script>
<script type='text/javascript' id='jquery-ui-datepicker-js-after'>
jQuery(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' id='wpeasycart_js-js-extra'>
/* <![CDATA[ */
var wpeasycart_ajax_object = {"ajax_url":"https:\/\/quimbyscruisingguide.com\/wp-admin\/admin-ajax.php","current_language":"EN"};
/* ]]> */
</script>
<script type='text/javascript' src='https://quimbyscruisingguide.com/wp-content/plugins/wp-easycart/design/theme/base-responsive-v3/ec-store.js?ver=5_3_4' id='wpeasycart_js-js'></script>
<script type='text/javascript' src='https://quimbyscruisingguide.com/wp-content/plugins/wp-easycart/design/theme/base-responsive-v3/owl.carousel.min.js?ver=5_3_4' id='wpeasycart_owl_carousel_js-js'></script>
<link rel="https://api.w.org/" href="https://quimbyscruisingguide.com/wp-json/" /><link rel="alternate" type="application/json" href="https://quimbyscruisingguide.com/wp-json/wp/v2/posts/13330" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://quimbyscruisingguide.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://quimbyscruisingguide.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://quimbyscruisingguide.com/?p=13330' />
<link rel="alternate" type="application/json+oembed" href="https://quimbyscruisingguide.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fquimbyscruisingguide.com%2Fmoveable-feast%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://quimbyscruisingguide.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fquimbyscruisingguide.com%2Fmoveable-feast%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.8.18 Professional to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->


<style>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</style>			<link rel="preload" href="https://quimbyscruisingguide.com/wp-content/plugins/wordpress-popup/assets/hustle-ui/fonts/hustle-icons-font.woff2" as="font" type="font/woff2" crossorigin>
		<link rel="icon" href="https://quimbyscruisingguide.com/wp-content/uploads/2022/03/cropped-quimbys-icon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://quimbyscruisingguide.com/wp-content/uploads/2022/03/cropped-quimbys-icon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://quimbyscruisingguide.com/wp-content/uploads/2022/03/cropped-quimbys-icon-180x180.png" />
<meta name="msapplication-TileImage" content="https://quimbyscruisingguide.com/wp-content/uploads/2022/03/cropped-quimbys-icon-270x270.png" />
	</head>
	<body class="post-template-default single single-post postid-13330 single-format-standard">
        <div id="wrapper">
            <!-- header of the page -->
            <header id="header">
                <div class="container">
					<div class="header-holder">
						<div class="logo"><a href="https://quimbyscruisingguide.com"><img src="https://quimbyscruisingguide.com/wp-content/themes/quimbys/images/logo.svg" alt="Quimby&#039;s Cruising Guide" width="278" height="76"></a></div>
													<nav id="nav">
                                <a class="nav-opener" href="#"><span>Open</span></a>
								<div class="nav-drop">
									<ul id="primary-menu" class="primary-menu"><li id="menu-item-29066" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-29066"><a href="#">Explore by Waterway</a>
<ul class="sub-menu">
	<li id="menu-item-28719" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28719"><a href="https://quimbyscruisingguide.com/category/cumberland-river/">Cumberland River</a></li>
	<li id="menu-item-143" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-143"><a href="https://quimbyscruisingguide.com/category/mississippi-river/">Mississippi River</a></li>
	<li id="menu-item-28724" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28724"><a href="https://quimbyscruisingguide.com/category/tennessee-river/">Tennessee River</a></li>
	<li id="menu-item-28720" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28720"><a href="https://quimbyscruisingguide.com/category/gulf-intracoastal/">Gulf Intracoastal</a></li>
	<li id="menu-item-28929" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28929"><a href="https://quimbyscruisingguide.com/category/monongahela-river/">Monongahela River</a></li>
	<li id="menu-item-28723" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28723"><a href="https://quimbyscruisingguide.com/category/tenn-tom-waterway/">Tenn-Tom Waterway</a></li>
	<li id="menu-item-28721" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28721"><a href="https://quimbyscruisingguide.com/category/illinois-waterway/">Illinois Waterway</a></li>
	<li id="menu-item-29121" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29121"><a href="https://quimbyscruisingguide.com/category/ohio-river/">Ohio River</a></li>
</ul>
</li>
<li id="menu-item-28846" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-28846"><a href="#">Latest News</a>
<ul class="sub-menu">
	<li id="menu-item-28848" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28848"><a href="https://quimbyscruisingguide.com/category/destinations/">Destinations</a></li>
	<li id="menu-item-28852" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28852"><a href="https://quimbyscruisingguide.com/category/boats/">Boats</a></li>
	<li id="menu-item-28849" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor active current-post-parent menu-item-28849"><a href="https://quimbyscruisingguide.com/category/lifestyle/">Lifestyle</a></li>
	<li id="menu-item-28851" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor active current-post-parent menu-item-28851"><a href="https://quimbyscruisingguide.com/category/skills/">Skills</a></li>
	<li id="menu-item-28850" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28850"><a href="https://quimbyscruisingguide.com/category/news/">News &#038; Extras</a></li>
</ul>
</li>
<li id="menu-item-28872" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28872"><a href="https://quimbyscruisingguide.com/cart/">Cart</a></li>
</ul>                                                                            <a class="btn btn-warning" href="https://quimbyscruisingguide.com/store/" >Store</a>
                                    								</div>
							</nav>
											</div>
                </div>
            </header>
            <!-- contain main informative part of the site -->
            <main id="main">
                    <section class="section-single-heading" style="background-image: linear-gradient(to top, rgba(255, 255, 255, 1) 0%, rgba(255, 255, 255, 0.8) 20%, rgba(255, 255, 255, 0.6) 40%, rgba(255, 255, 255, 0.4) 60%, rgba(255, 255, 255, 0.2) 80%, rgba(255, 255, 255, 0.01) 100%), url(https://quimbyscruisingguide.com/wp-content/themes/quimbys/images/links-bg.png)">
            <div class="container">
                <div class="section-inner">
                    <div class="featured-news-story">
                        <div class="featured-news-story-title">
                            <h1>Entertaining on Board Your Boat</h1>                            <div class="meta">
                                <span>By <a href="https://quimbyscruisingguide.com/author/quimbys-editor/">Quimbys Editor</a></span><span class="separator">|</span>
                                <time datatime="2022-06-02"><a href="https://quimbyscruisingguide.com/2022/06/" rel="bookmark">June 2, 2022</a></time>
                            </div>
                        </div>
                                                    <div class="img-holder">
                                <img width="670" height="400" src="https://quimbyscruisingguide.com/wp-content/uploads/2015/06/Boat-Grill-670x400.jpg" class="attachment-thumbnail_670x400 size-thumbnail_670x400 wp-post-image" alt="" />                                                                    <a class="category_el" href="https://quimbyscruisingguide.com/category/lifestyle/"><span>Lifestyle</span></a>
                                                            </div>
                                            </div>
                </div>
            </div>
        </section>
        <div class="container">
            <div id="twocolumns">
                <div id="content">
                    <div class="g-container">Hosting friends and family on board ranks as the No. 2 reason for having a boat on many U.S. boat owners’ lists — right after the vessel’s primary use of cruising, fishing, waterskiing, etc. With so much entertaining going on, it seemed appropriate to provide our tips for having a successful on-water gathering, whether your boat is large or small.</p>
<p>The first step for low-stress entertaining is to make a list. A well thought out list will help ensure you don’t forget to bring along critical items and ingredients. At the opposite end of the spectrum, don’t go overboard trying to plan for every eventuality. Inclement weather? Yes. (Have the canvas ready and bring windbreakers.) Tidal wave? Probably not.</p>
<p>Unless you own a luxury yacht, it’s best to keep the serving casual and let guests help themselves. If you want to have a fancy dinner party, cook on land and bring the dishes aboard. Nothing can take the mood of a party down faster than a frustrated boat owner trying to cook something complex in a small galley.</p>
<p>Speaking of which, to increase workspace in your galley, fabricate wooden or starboard covers for the stove burners and sink. Keep equipment to a minimum: one skillet, one pot/saucepan. Even if there’s a large fridge on board, bring a cooler for drinks and place it in the cockpit or other key location. This will keep guests in the thick of the fun, where they should be, rather than in your way.</p>
<p><strong>Nautical Edibles</strong><br />
Bring along food that can be easily assembled on board yet is still a treat for the taste buds, like fresh basil, tomatoes and mozzarella, which can be simply sliced and plated. Salads that can be served at room temperature — such as cucumber salad — are excellent for warm-weather entertaining. Precooked shrimp is good to eat cold or tossed on the grill. Avoid serving greasy food that could lead to queasy stomachs and exacerbate seasickness.</p>
<p>We all know to avoid food that will roll around and fall from a plate. But in addition to the old trick of squaring off meatballs, melon balls and other round foods, realize that hamburgers are more stable than hotdogs or brats.</p>
<p>If you want to serve grilled corn on the cob, cut the ears into 1-inch rounds so they lay on their side on a plate. This makes them into handy finger food. Similarly, mashed potatoes make a better side dish than their baked cousins and allow guests to take as much or as little as they like.</p>
<p>If you’re looking for food that will go with many things yet will stay fresh for a long time in the galley, the answer is rice. Stored in a cool, well-ventilated place, rice will keep for months. Wash old rice before cooking to remove any starch buildup.</p>
<p>Never rely on catching fish; always have a backup plan. It’s better to have leftovers than to run out of food. That said, bring along your favorite spices for when you <em>do</em> have a good day’s catch.</p>
<p>Desserts can be as simple as fresh strawberries with whipped cream. Remember, everything tastes more exotic on a boat.</p>
<p>Don’t forget to ask boat guests if they have any food allergies. You don’t want to discover this miles offshore.</p>
<p><strong>Beyond the Menu</strong><br />
Two other key considerations when entertaining aboard, especially during the height of summer, are seating and shade.</p>
<p>Make sure there’s enough of the former — and in the areas where you want it. If seating is at a premium, consider purchasing a few folding deck chairs. These are especially useful if you want to turn a large swim platform into a comfortable water-access “patio.”</p>
<p>Shade enhancement can range from inexpensive, compact, portable chair umbrellas for the aforementioned swim platform to extending the boat’s hardtop or bimini with a canvas awning to provide coverage for large groups. Having a stash of hats and sunglasses available for guests to use never hurts, either.</p>
<p>Once you’ve planned as well as you can, cast off and be sure to not stress out and have fun on the water — because that’s what entertaining on board is all about.</p>
<p><em>Author: Sandy Lindsey </em></div>
                                    </div>
                <aside id="sidebar">
                    <div class="widget">
                        									<div class="sales-box-grid" style="background-image: linear-gradient(to top, #e7f0f9 0%, rgba(227, 236, 245, 0) 100%), url(https://quimbyscruisingguide.com/wp-content/themes/quimbys/images/links-bg.png)">
										<div class="headline">
					<p>The <strong>Complete Listing of Marinas and Locks</strong> on the Inland and Gulf Intracoastal Waterways</p>
				</div>
										<div class="btn-holder">
					<a class="btn btn-default" href="https://quimbyscruisingguide.com/store/?model_number=2022-quimbys-cruising-guide" target="_blank">Explore the Guide</a>
				</div>
					</div>
	                    </div>
                    <div class="widget">
                        <div class="poster">	<div class="g g-4"><div class="g-single a-4"><a class="gofollow" data-track="NCw0LDEsNjA=" href="https://quimbyscruisingguide.com/store/?model_number=2022-quimbys-cruising-guide" target="_blank"><img src="https://quimbyscruisingguide.com/wp-content/uploads/2022/05/Quimbys22_300x250.jpg" /></a></div></div></div>
                    </div>
                </aside>
            </div>
        </div>
        <div class="section-poster">
            <div class="container">	<div class="g g-3"><div class="g-single a-3"><a class="gofollow" data-track="MywzLDEsNjA=" href="http://aquayachtharbor.com/" target="_blank"><img src="https://quimbyscruisingguide.com/wp-content/uploads/2022/04/shm-ms-ayh-banner-970x90-1.jpeg" /></a></div></div></div>
        </div>
                    <section class="section-title-box">
                <div class="container">
                    <h2>Explore More from Quimby’s</h2>
                </div>
            </section>
                        <section class="section-cards">
            <div class="container">
                <div class="cards-grid">
                                            <div class="card">
			<div class="card-visual">
			<a class="card-img" href="https://quimbyscruisingguide.com/fathers-day-gift-guide/">
				<img width="980" height="551" src="https://quimbyscruisingguide.com/wp-content/uploads/2021/06/swiftknot_2-980x551.jpg" class="attachment-thumbnail_980x551 size-thumbnail_980x551 wp-post-image" alt="" loading="lazy" />			</a>
							<a class="category_el" href="https://quimbyscruisingguide.com/category/boats/"><span>Boats</span></a>
					</div>
		<div class="card-body">
		<h5 class="card-title"><a href="https://quimbyscruisingguide.com/fathers-day-gift-guide/" rel="bookmark">Father&#8217;s Day Gift Guide</a></h5>		<p>
			For those dads that like to boat, there is no better gift than a boating accessory for Father&#8217;s Day. Here are six great accessories that make for the perfect Father&#8217;s Day gift. BOTE Hangout Dock You can get something that dad will enjoy with the whole family with the all-new BOTE Hangout Dock. Manufactured by [&hellip;]			<a href="https://quimbyscruisingguide.com/fathers-day-gift-guide/">Read More</a>
					</p>
	</div>
</div>
                                            <div class="card">
			<div class="card-visual">
			<a class="card-img" href="https://quimbyscruisingguide.com/2022-quimbys-cruising-guide/">
				<img width="980" height="551" src="https://quimbyscruisingguide.com/wp-content/uploads/2022/04/IMG_8710-scaled-1-980x551.jpeg" class="attachment-thumbnail_980x551 size-thumbnail_980x551 wp-post-image" alt="" loading="lazy" />			</a>
							<a class="category_el" href="https://quimbyscruisingguide.com/category/destinations/"><span>Destinations</span></a>
					</div>
		<div class="card-body">
		<h5 class="card-title"><a href="https://quimbyscruisingguide.com/2022-quimbys-cruising-guide/" rel="bookmark">2022 Quimby&#8217;s Cruising Guide</a></h5>		<p>
			5,000 miles, 11 different waterways and two countries—America’s Great Loop is truly one of the most unique travel experiences in the World.			<a href="https://quimbyscruisingguide.com/2022-quimbys-cruising-guide/">Read More</a>
					</p>
	</div>
</div>
                                    </div>
            </div>
        </section>
                    </main>
            <!-- footer of the page -->
            <footer id="footer">
                <div class="footer-top">
                    <div class="container">
                        <nav class="footer-nav">
                            <ul id="footer-nav-main" class="footer-nav-main"><li id="menu-item-28857" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28857"><a href="https://quimbyscruisingguide.com/about-quimbys/">About Quimby’s</a></li>
<li id="menu-item-28859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28859"><a href="https://quimbyscruisingguide.com/advertise/">Advertise With Us</a></li>
<li id="menu-item-28861" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28861"><a href="https://quimbyscruisingguide.com/contact-quimbys/">Contact Quimby’s</a></li>
<li id="menu-item-28868" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28868"><a href="https://www.facebook.com/quimbysguide/">Facebook</a></li>
<li id="menu-item-28858" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28858"><a href="https://quimbyscruisingguide.com/account/">My Account</a></li>
</ul>                                                    </nav>
                    </div>
                </div>
                <div class="footer-bottom">
                    <div class="container">
                                                <div class="copyright">
                            <p>© 2022 Bound Media Group | All Rights Reserved</p>
                        </div>
                        <nav class="menu-bottom-wrap">
                            <ul id="menu-bottom" class="menu-bottom"><li id="menu-item-28718" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28718"><a href="https://quimbyscruisingguide.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-28715" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-28715"><a href="https://quimbyscruisingguide.com/privacy-policy/">Privacy Policy</a></li>
</ul>                        </nav>
                        
						<small>Website by <a href="https://hubandspokecreative.com/" alt="st. louis website design and marketing agency">Hub &amp; Spoke</a></small>
                        
                    </div>
                </div>
            </footer>
        </div>
        <link rel='stylesheet' id='hustle_icons-css'  href='https://quimbyscruisingguide.com/wp-content/plugins/wordpress-popup/assets/hustle-ui/css/hustle-icons.min.css?ver=4.4.13.1' type='text/css' media='all' />
<link rel='stylesheet' id='hustle_global-css'  href='https://quimbyscruisingguide.com/wp-content/plugins/wordpress-popup/assets/hustle-ui/css/hustle-global.min.css?ver=4.4.13.1' type='text/css' media='all' />
<link rel='stylesheet' id='hustle_optin-css'  href='https://quimbyscruisingguide.com/wp-content/plugins/wordpress-popup/assets/hustle-ui/css/hustle-optin.min.css?ver=4.4.13.1' type='text/css' media='all' />
<link rel='stylesheet' id='hustle_inline-css'  href='https://quimbyscruisingguide.com/wp-content/plugins/wordpress-popup/assets/hustle-ui/css/hustle-inline.min.css?ver=4.4.13.1' type='text/css' media='all' />
<link rel='stylesheet' id='hustle-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A700%2Cregular%2Cbold&#038;display=swap&#038;ver=1.0' type='text/css' media='all' />
<script type='text/javascript' id='adrotate-clicktracker-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/quimbyscruisingguide.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://quimbyscruisingguide.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js' id='adrotate-clicktracker-js'></script>
<script type='text/javascript' id='hui_scripts-js-extra'>
/* <![CDATA[ */
var hustleSettings = {"mobile_breakpoint":"782"};
/* ]]> */
</script>
<script type='text/javascript' src='https://quimbyscruisingguide.com/wp-content/plugins/wordpress-popup/assets/hustle-ui/js/hustle-ui.min.js?ver=4.4.13.1' id='hui_scripts-js'></script>
<script type='text/javascript' src='https://quimbyscruisingguide.com/wp-includes/js/underscore.min.js?ver=1.13.3' id='underscore-js'></script>
<script type='text/javascript' id='hustle_front-js-extra'>
/* <![CDATA[ */
var Modules = [{"settings":{"auto_close_success_message":"0","triggers":{"on_time_delay":"0","on_time_unit":"seconds","on_scroll":"scrolled","on_scroll_page_percent":20,"on_scroll_css_selector":"","enable_on_click_element":"1","on_click_element":"","enable_on_click_shortcode":"1","on_exit_intent_per_session":"1","on_exit_intent_delayed_time":"0","on_exit_intent_delayed_unit":"seconds","on_adblock_delay":"0","on_adblock_delay_unit":"seconds","trigger":["time"]},"animation_in":"no_animation","animation_out":"no_animation","after_close":"keep_show","expiration":365,"expiration_unit":"days","on_submit":"nothing","on_submit_delay":"5","on_submit_delay_unit":"seconds","close_cta":"0","close_cta_time":"0","close_cta_unit":"seconds","hide_after_cta":"keep_show","hide_after_subscription":"keep_show","is_schedule":"0","schedule":{"not_schedule_start":"1","start_date":"03\/03\/2022","start_hour":"12","start_minute":"00","start_meridiem_offset":"am","not_schedule_end":"1","end_date":"03\/09\/2022","end_hour":"11","end_minute":"59","end_meridiem_offset":"pm","active_days":"all","week_days":[],"is_active_all_day":"1","day_start_hour":"00","day_start_minute":"00","day_start_meridiem_offset":"am","day_end_hour":"11","day_end_minute":"59","day_end_meridiem_offset":"pm","time_to_use":"server","custom_timezone":"UTC"},"after_close_trigger":["click_close_icon"]},"module_id":"1","blog_id":"0","module_name":"Stay in the know.","module_type":"embedded","active":"1","module_mode":"optin"}];
var incOpt = {"conditional_tags":{"is_single":true,"is_tag":false,"is_category":false,"is_author":false,"is_date":false,"is_post_type_archive":false,"is_404":false,"is_front_page":false,"is_search":false},"is_admin":"","real_page_id":"","thereferrer":"","actual_url":"quimbyscruisingguide.com\/moveable-feast\/","full_actual_url":"https:\/\/quimbyscruisingguide.com\/moveable-feast\/","native_share_enpoints":{"facebook":"https:\/\/www.facebook.com\/sharer\/sharer.php?u=https%3A%2F%2Fquimbyscruisingguide.com%2Fmoveable-feast","twitter":"https:\/\/twitter.com\/intent\/tweet?url=https%3A%2F%2Fquimbyscruisingguide.com%2Fmoveable-feast&text=Entertaining%20on%20Board%20Your%20Boat","pinterest":"https:\/\/www.pinterest.com\/pin\/create\/button\/?url=https%3A%2F%2Fquimbyscruisingguide.com%2Fmoveable-feast","reddit":"https:\/\/www.reddit.com\/submit?url=https%3A%2F%2Fquimbyscruisingguide.com%2Fmoveable-feast","linkedin":"https:\/\/www.linkedin.com\/shareArticle?mini=true&url=https%3A%2F%2Fquimbyscruisingguide.com%2Fmoveable-feast","vkontakte":"https:\/\/vk.com\/share.php?url=https%3A%2F%2Fquimbyscruisingguide.com%2Fmoveable-feast","whatsapp":"https:\/\/api.whatsapp.com\/send?text=https%3A%2F%2Fquimbyscruisingguide.com%2Fmoveable-feast","email":"mailto:?subject=Entertaining%20on%20Board%20Your%20Boat&body=https%3A%2F%2Fquimbyscruisingguide.com%2Fmoveable-feast"},"ajaxurl":"https:\/\/quimbyscruisingguide.com\/wp-admin\/admin-ajax.php","page_id":"13330","page_slug":"moveable-feast","is_upfront":"","script_delay":"3000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://quimbyscruisingguide.com/wp-content/plugins/wordpress-popup/assets/js/front.min.js?ver=4.4.13.1' id='hustle_front-js'></script>
<script type='text/javascript' src='https://quimbyscruisingguide.com/wp-content/themes/quimbys/js/jquery.main.js?ver=6.0' id='base-script-js'></script>
<script type='text/javascript' src='https://kit.fontawesome.com/6fce604609.js?ver=6.0' id='fontawesome-js'></script>
<script type='text/javascript' id='gforms_recaptcha_recaptcha-js-extra'>
/* <![CDATA[ */
var gforms_recaptcha_recaptcha_strings = {"site_key":"6LczM2QbAAAAABQ_AlTGLnVFzHw8ON60_9QP8c43","ajaxurl":"https:\/\/quimbyscruisingguide.com\/wp-admin\/admin-ajax.php","nonce":"288ad98db9"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LczM2QbAAAAABQ_AlTGLnVFzHw8ON60_9QP8c43&#038;ver=1.1' id='gforms_recaptcha_recaptcha-js'></script>
<script type='text/javascript' id='gforms_recaptcha_recaptcha-js-after'>
(function($){grecaptcha.ready(function(){$('.grecaptcha-badge').css('visibility','hidden');});})(jQuery);
</script>
    </body>
</html>
<!-- Page supported by LiteSpeed Cache 4.6 on 2022-06-03 15:31:41 -->